Tech Talk

Update your browser to keep making L$ payments

Linden Lab recently made an announcement that a web browser supporting TLS v1.2 will be required from June 15, 2016 to access SecondLife’s web cashier to make payments or exchange L$. 

The most recent versions of Chrome, Firefox, Safari or Microsoft Edge all have this support, as does the most recent version of the SecondLife viewer in addition to Kokua 4.0.2 or higher. 

If in doubt, you can check your browser by visiting https://www.howsmyssl.com/ or check the support pages of your favorite viewer for accessing the SecondLife grid. 

hypergrid address: hop://grid.xmir.org:8002                                             xmir © 2014-2017